<!doctype html >
<!--[if IE 8]><html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]><html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--><html lang="en-US" prefix="og: https://ogp.me/ns# fb: http://ogp.me/ns/fb#"> <!--<![endif]--><head><title>Queen Remembers The Band&#039;s Special Day</title><meta charset="UTF-8" /><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin /><script>WebFontConfig={google:{families:['Mako:400','Cambo:400','Roboto:300,400,400italic,500,500italic,700,900','Averia Serif Libre:400','Basic:400','Open Sans:300italic,400,400italic,600,600italic,700']}};</script><script id="litespeed-webfont-lib" src="https://www.metalcastle.net/wp-content/plugins/litespeed-cache/js/webfontloader.min.js" async></script> <meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="pingback" href="https://www.metalcastle.net/xmlrpc.php" /><meta property="og:image" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><link rel="icon" type="image/png" href="https://www.metalcastle.net/wp-content/uploads/2019/04/KÜÇÜK-İKON.png"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="https://www.metalcastle.net/wp-content/uploads/2019/04/76.png" /><link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://www.metalcastle.net/wp-content/uploads/2019/04/120-1.png" /><link rel="apple-touch-icon-precomposed" sizes="152x152" href="https://www.metalcastle.net/wp-content/uploads/2019/04/152-1.png" /><link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://www.metalcastle.net/wp-content/uploads/2019/04/114-1.png" /><link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://www.metalcastle.net/wp-content/uploads/2019/04/144-1.png" /><meta name="description" content="Queen has just shared a new post and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974. | MetalCastle - All about Rock and Metal" /><meta name="keywords" content="news,queen,queen news,rock,rock news" /> <script type="application/ld+json" class="aioseop-schema">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.metalcastle.net/#organization","url":"https://www.metalcastle.net/","name":"MetalCastle - All about Rock and Metal","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://www.metalcastle.net/#logo","url":"https://www.metalcastle.net/wp-content/uploads/2019/11/metalcastle-footer.png","caption":""},"image":{"@id":"https://www.metalcastle.net/#logo"}},{"@type":"WebSite","@id":"https://www.metalcastle.net/#website","url":"https://www.metalcastle.net/","name":"MetalCastle - All about Rock and Metal","publisher":{"@id":"https://www.metalcastle.net/#organization"}},{"@type":"WebPage","@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#webpage","url":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/","inLanguage":"en-US","name":"Queen Remembers The Band&#8217;s Special Day","isPartOf":{"@id":"https://www.metalcastle.net/#website"},"image":{"@type":"ImageObject","@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#primaryimage","url":"https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg","width":850,"height":483},"primaryImageOfPage":{"@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#primaryimage"},"datePublished":"2020-03-08T23:28:40+00:00","dateModified":"2020-03-08T23:28:40+00:00","description":"Queen has just shared a new post and celebrated the anniversary of the band's second studio album called Queen II, which was released on March 8, 1974."},{"@type":"Article","@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#article","isPartOf":{"@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#webpage"},"author":{"@id":"https://www.metalcastle.net/author/eray-erel/#author"},"headline":"Queen Remembers The Band&#8217;s Special Day","datePublished":"2020-03-08T23:28:40+00:00","dateModified":"2020-03-08T23:28:40+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#webpage"},"publisher":{"@id":"https://www.metalcastle.net/#organization"},"articleSection":"NEWS, ROCK, news, queen, queen news, rock, rock news","image":{"@type":"ImageObject","@id":"https://www.metalcastle.net/queen-remembers-the-bands-special-day/#primaryimage","url":"https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg","width":850,"height":483}},{"@type":"Person","@id":"https://www.metalcastle.net/author/eray-erel/#author","name":"Eray Erel","sameAs":["_erayerel"],"image":{"@type":"ImageObject","@id":"https://www.metalcastle.net/#personlogo","url":"https://www.metalcastle.net/wp-content/uploads/2020/01/eray-erel-metalcastlenet.png","width":96,"height":96,"caption":"Eray Erel"}}]}</script> <link rel="canonical" href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" /><meta property="og:type" content="article" /><meta property="og:title" content="Queen Remembers The Band&#039;s Special Day" /><meta property="og:description" content="Queen has just shared a new post and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974." /><meta property="og:url" content="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" /><meta property="og:site_name" content="MetalCastle - All about Rock and Metal" /><meta property="og:image" content="https://www.metalcastle.net/wp-content/plugins/all-in-one-seo-pack/images/default-user-image.png" /><meta property="article:published_time" content="2020-03-08T23:28:40Z" /><meta property="article:modified_time" content="2020-03-08T23:28:40Z" /><meta property="og:image:secure_url" content="https://www.metalcastle.net/wp-content/plugins/all-in-one-seo-pack/images/default-user-image.png" /><meta name="twitter:card" content="summary" /><meta name="twitter:title" content="Queen Remembers The Band&#039;s Special Day" /><meta name="twitter:description" content="Queen has just shared a new post and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974." /><meta name="twitter:image" content="https://www.metalcastle.net/wp-content/plugins/all-in-one-seo-pack/images/default-user-image.png" /> <script type="text/javascript">window.ga=window.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;ga('create','UA-138085751-1','auto');ga('send','pageview');</script> <script async src="https://www.google-analytics.com/analytics.js"></script> <link rel="amphtml" href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/amp/" /><meta name="generator" content="AMP for WP 1.0.29" /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="MetalCastle - All about Rock and Metal &raquo; Feed" href="https://www.metalcastle.net/feed/" /><link rel="alternate" type="application/rss+xml" title="MetalCastle - All about Rock and Metal &raquo; Comments Feed" href="https://www.metalcastle.net/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="MetalCastle - All about Rock and Metal &raquo; Queen Remembers The Band&#8217;s Special Day Comments Feed" href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/feed/" /> <script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.metalcastle.net\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-.1em !important;background:0 0 !important;padding:0 !important}</style><link data-optimized='1' rel='stylesheet' id='wp-block-library-css' href='https://www.metalcastle.net/min/2e52f.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='ads-for-wp-front-css-css' href='https://www.metalcastle.net/min/332c3.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='contact-form-7-css' href='https://www.metalcastle.net/min/b7126d2c2b6e265a442e38f9edb32d76.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='cookie-notice-front-css' href='https://www.metalcastle.net/min/0c1a3.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.metalcastle.net/min/fa10c.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='js_composer_front-css' href='https://www.metalcastle.net/min/2d0c4.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='td-theme-css' href='https://www.metalcastle.net/min/b4c30.css' type='text/css' media='all' /><link data-optimized='1' rel='stylesheet' id='td-theme-demo-style-css' href='https://www.metalcastle.net/min/bad7b.css' type='text/css' media='all' /> <script type='text/javascript' src='https://www.metalcastle.net/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/62032.js'></script> <script type='text/javascript'>var cnArgs={"ajaxurl":"https:\/\/www.metalcastle.net\/wp-admin\/admin-ajax.php","hideEffect":"slide","onScroll":"no","onScrollOffset":"100","onClick":"","cookieName":"cookie_notice_accepted","cookieValue":"true","cookieTime":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"","cache":"1","refuse":"no","revoke_cookies":"0","revoke_cookies_opt":"automatic","secure":"1"};</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/f5f35.js'></script> <link rel='https://api.w.org/' href='https://www.metalcastle.net/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.metalcastle.net/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.metalcastle.net/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way' href='https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/' /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://www.metalcastle.net/?p=6931' /><link rel="alternate" type="application/json+oembed" href="https://www.metalcastle.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.metalcastle.net%2Fqueen-remembers-the-bands-special-day%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.metalcastle.net/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.metalcastle.net%2Fqueen-remembers-the-bands-special-day%2F&#038;format=xml" /> <script type="text/javascript">jQuery(document).ready(function($){if($('#adsforwp-hidden-block').length==0){$.getScript("https://www.metalcastle.net/front.js");}});</script> <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script> <script>googletag.cmd.push(function(){googletag.defineSlot('',[,],'').addService(googletag.pubads());googletag.defineSlot('',[,],'').addService(googletag.pubads());googletag.defineSlot('',[,],'').addService(googletag.pubads());googletag.defineSlot('',[,],'').addService(googletag.pubads());googletag.pubads().enableSingleRequest();googletag.enableServices();});</script> <script>window.tdwGlobal={"adminUrl":"https:\/\/www.metalcastle.net\/wp-admin\/","wpRestNonce":"97dcbac872","wpRestUrl":"https:\/\/www.metalcastle.net\/wp-json\/","permalinkStructure":"\/%postname%\/"};</script> <!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]--><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.metalcastle.net/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta name="onesignal" content="wordpress-plugin" /> <script>window.OneSignal=window.OneSignal||[];OneSignal.push(function(){OneSignal.SERVICE_WORKER_UPDATER_PATH="OneSignalSDKUpdaterWorker.js.php";OneSignal.SERVICE_WORKER_PATH="OneSignalSDKWorker.js.php";OneSignal.SERVICE_WORKER_PARAM={scope:'/'};OneSignal.setDefaultNotificationUrl("https://www.metalcastle.net");var oneSignal_options={};window._oneSignalInitOptions=oneSignal_options;oneSignal_options['wordpress']=true;oneSignal_options['appId']='a7a10616-a310-4fa7-9db5-dbdf952d436f';oneSignal_options['welcomeNotification']={};oneSignal_options['welcomeNotification']['title']="";oneSignal_options['welcomeNotification']['message']="";oneSignal_options['path']="https://www.metalcastle.net/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";oneSignal_options['safari_web_id']="web.onesignal.auto.516349e1-446e-4cea-8b68-2396bd3ac49a";oneSignal_options['persistNotification']=true;oneSignal_options['promptOptions']={};oneSignal_options['notifyButton']={};oneSignal_options['notifyButton']['enable']=true;oneSignal_options['notifyButton']['position']='bottom-left';oneSignal_options['notifyButton']['theme']='default';oneSignal_options['notifyButton']['size']='large';oneSignal_options['notifyButton']['showCredit']=true;oneSignal_options['notifyButton']['text']={};OneSignal.init(window._oneSignalInitOptions);OneSignal.showSlidedownPrompt();});function documentInitOneSignal(){var oneSignal_elements=document.getElementsByClassName("OneSignal-prompt");var oneSignalLinkClickHandler=function(event){OneSignal.push(['registerForPushNotifications']);event.preventDefault();};for(var i=0;i<oneSignal_elements.length;i++)
oneSignal_elements[i].addEventListener('click',oneSignalLinkClickHandler,false);}
if(document.readyState==='complete'){documentInitOneSignal();}
else{window.addEventListener("load",function(event){documentInitOneSignal();});}</script> <script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type1";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img[class*=\"wp-image-\"], a.td-sml-link-to-image > img";var td_animation_stack_general_selectors=".td-animation-stack .entry-thumb, .post .entry-thumb, .post img[class*=\"wp-image-\"], .post a.td-sml-link-to-image > img";var td_ajax_url="https:\/\/www.metalcastle.net\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.6.1";var td_get_template_directory_uri="https:\/\/www.metalcastle.net\/wp-content\/themes\/Newspaper";var tds_snap_menu="smart_snap_always";var tds_logo_on_sticky="show";var tds_header_style="10";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#686868";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="_blank";</script> <style>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</style> <script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.metalcastle.net/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.metalcastle.net/category/news/",
                    "name": "NEWS"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.metalcastle.net/queen-remembers-the-bands-special-day/",
                    "name": "Queen Remembers The Band&#8217;s Special Day"                                
                }
            }    
        ]
    }
</script> <link rel="icon" href="https://www.metalcastle.net/wp-content/uploads/2019/04/cropped-KÜÇÜK-İKON-2-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.metalcastle.net/wp-content/uploads/2019/04/cropped-KÜÇÜK-İKON-2-192x192.png" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://www.metalcastle.net/wp-content/uploads/2019/04/cropped-KÜÇÜK-İKON-2-180x180.png" /><meta name="msapplication-TileImage" content="https://www.metalcastle.net/wp-content/uploads/2019/04/cropped-KÜÇÜK-İKON-2-270x270.png" /><style>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</style><noscript><style type="text/css">.wpb_animate_when_almost_visible{opacity:1}</style></noscript><meta property="og:locale" content="en_US" /><meta property="og:site_name" content="MetalCastle - All about Rock and Metal" /><meta property="og:title" content="Queen Remembers The Band&#039;s Special Day" /><meta property="og:url" content="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" /><meta property="og:type" content="article" /><meta property="og:description" content="The 50-year legendary rock band Queen has just updated its social media account and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974.In the photo, there was a legendary members of the Queen. Also, Freddie Mercury, who died at the a" /><meta property="og:image" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><meta property="og:image:url" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><meta property="og:image:secure_url" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><meta property="article:published_time" content="2020-03-08T23:28:40+00:00" /><meta property="article:modified_time" content="2020-03-08T23:28:40+00:00" /><meta property="og:updated_time" content="2020-03-08T23:28:40+00:00" /><meta property="article:section" content="NEWS" /><meta property="article:section" content="ROCK" /><meta property="article:publisher" content="https://www.facebook.com/MetalCastlenet-652784258492497/?modal=admin_todo_tour" /><meta itemprop="name" content="Queen Remembers The Band&#039;s Special Day" /><meta itemprop="headline" content="Queen Remembers The Band&#039;s Special Day" /><meta itemprop="description" content="The 50-year legendary rock band Queen has just updated its social media account and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974.In the photo, there was a legendary members of the Queen. Also, Freddie Mercury, who died at the a" /><meta itemprop="image" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><meta itemprop="datePublished" content="2020-03-08" /><meta itemprop="dateModified" content="2020-03-08T23:28:40+00:00" /><meta itemprop="author" content="Eray Erel" /><meta name="twitter:title" content="Queen Remembers The Band&#039;s Special Day" /><meta name="twitter:url" content="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" /><meta name="twitter:description" content="The 50-year legendary rock band Queen has just updated its social media account and celebrated the anniversary of the band&#039;s second studio album called Queen II, which was released on March 8, 1974.In the photo, there was a legendary members of the Queen. Also, Freddie Mercury, who died at the a" /><meta name="twitter:image" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@_erayerel" /><meta name="twitter:site" content="@metalcastlenet" />
<style id="tdw-css-placeholder"></style></head><body class="post-template-default single single-post postid-6931 single-format-standard cookies-not-set queen-remembers-the-bands-special-day global-block-template-14 td-college single_template_2 wpb-js-composer js-comp-ver-5.7 vc_responsive td-animation-stack-type1 td-boxed-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage"><div class="td-scroll-up"><i class="td-icon-menu-up"></i></div><div class="td-menu-background"></div><div id="td-mobile-nav"><div class="td-mobile-container"><div class="td-menu-socials-wrap"><div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/metalcastlenet" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/metalcastle_official/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/metalcastle_net" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/metalcastlenet" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCcSTPDmL6d7rNodaHqBCeVg" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></div><div class="td-mobile-close">
<a href="#"><i class="td-icon-close-mobile"></i></a></div></div><div class="td-mobile-content"><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-37" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-37"><a href="https://www.metalcastle.net/">HOME</a></li><li id="menu-item-187" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-187"><a href="https://www.metalcastle.net/category/news/rock/">ROCK</a></li><li id="menu-item-360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-360"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></li><li id="menu-item-186" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-186"><a href="https://www.metalcastle.net/category/news/">NEWS</a></li><li id="menu-item-3808" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3808"><a href="https://www.metalcastle.net/category/news/others/">OTHERS</a></li><li id="menu-item-188" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-188"><a href="https://www.metalcastle.net/category/bands/">BANDS</a></li><li id="menu-item-192" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-192"><a href="https://www.metalcastle.net/category/videos/">VIDEOS<i class="td-icon-menu-right td-element-after"></i></a><ul class="sub-menu"><li id="menu-item-0" class="menu-item-0"><a href="https://www.metalcastle.net/category/videos/cover/">COVER</a></li><li class="menu-item-0"><a href="https://www.metalcastle.net/category/videos/interviews/">INTERVIEWS</a></li><li class="menu-item-0"><a href="https://www.metalcastle.net/category/videos/live/">LIVE</a></li><li class="menu-item-0"><a href="https://www.metalcastle.net/category/videos/offical/">OFFICAL</a></li><li class="menu-item-0"><a href="https://www.metalcastle.net/category/videos/other-videos/">OTHER</a></li></ul></li></ul></div></div></div></div><div class="td-search-background"></div><div class="td-search-wrap-mob"><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.metalcastle.net/"><div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a></div><div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" /></div></form><div id="td-aj-search-mob"></div></div></div><style>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style><div id="td-outer-wrap" class="td-theme-wrap"><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-10 "><div class="td-header-top-menu-full td-container-wrap "><div class="td-container td-header-row td-header-top-menu"><div class="top-bar-style-2"><div class="td-header-sp-top-widget">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/metalcastlenet" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/metalcastle_official/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/metalcastle_net" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/metalcastlenet" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCcSTPDmL6d7rNodaHqBCeVg" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></div><div class="td-header-sp-top-menu"><div class="td_data_time"><div>Sunday, March 8, 2020</div></div><div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-3507" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-3507"><a href="https://www.metalcastle.net/about-us/">ABOUT US</a></li></ul></div></div></div></div></div><div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap "><div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.metalcastle.net/">
<img src="https://www.metalcastle.net/wp-content/uploads/2019/11/noname-1.png" alt="" />
<span class="td-visual-hidden">MetalCastle &#8211; All about Rock and Metal</span>
</a></div></div><div class="td-header-menu-wrap-full td-container-wrap "><div class="td-header-menu-wrap td-header-gradient "><div class="td-container td-header-row td-header-main-menu"><div id="td-header-menu" role="navigation"><div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-mobile" href="https://www.metalcastle.net/">
<img src="https://www.metalcastle.net/wp-content/uploads/2019/04/noname.png" alt="" />
</a>
<a class="td-header-logo td-sticky-mobile" href="https://www.metalcastle.net/">
<img src="https://www.metalcastle.net/wp-content/uploads/2019/11/noname-1.png" alt="" />
</a></div><div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-37"><a href="https://www.metalcastle.net/">HOME</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-mega-menu menu-item-187"><a href="https://www.metalcastle.net/category/news/rock/">ROCK</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_1_5e6580271b95b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_1_5e6580271b95b"><script>var block_td_uid_1_5e6580271b95b=new tdBlock();block_td_uid_1_5e6580271b95b.id="td_uid_1_5e6580271b95b";block_td_uid_1_5e6580271b95b.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"16","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5e6580271b95b_rand","tdc_css_class":"td_uid_1_5e6580271b95b_rand","tdc_css_class_style":"td_uid_1_5e6580271b95b_rand_style"}';block_td_uid_1_5e6580271b95b.td_column_number="3";block_td_uid_1_5e6580271b95b.block_type="td_block_mega_menu";block_td_uid_1_5e6580271b95b.post_count="5";block_td_uid_1_5e6580271b95b.found_posts="270";block_td_uid_1_5e6580271b95b.header_color="";block_td_uid_1_5e6580271b95b.ajax_pagination_infinite_stop="";block_td_uid_1_5e6580271b95b.max_num_pages="54";tdBlocksArray.push(block_td_uid_1_5e6580271b95b);</script><div id=td_uid_1_5e6580271b95b class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" rel="bookmark" class="td-image-wrap" title="Queen Remembers The Band&#8217;s Special Day"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Queen Remembers The Band&#8217;s Special Day" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" rel="bookmark" title="Queen Remembers The Band&#8217;s Special Day">Queen Remembers The Band&#8217;s Special Day</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" class="td-image-wrap" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/chris-slade-david-gilmour-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour">AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/guns-n-roses-icon-slash-breaks-his-silence-on-rhcps-john-frusciante/" rel="bookmark" class="td-image-wrap" title="Guns N&#8217; Roses Icon Slash Breaks His Silence on RHCP&#8217;s John Frusciante"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Guns N&#8217; Roses Icon Slash Breaks His Silence on RHCP&#8217;s John Frusciante" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/slash-john-frusciante-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/guns-n-roses-icon-slash-breaks-his-silence-on-rhcps-john-frusciante/" rel="bookmark" title="Guns N&#8217; Roses Icon Slash Breaks His Silence on RHCP&#8217;s John Frusciante">Guns N&#8217; Roses Icon Slash Breaks His Silence on RHCP&#8217;s John&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/the-special-birthday-message-from-pink-floyd-to-david-gilmour-revealed/" rel="bookmark" class="td-image-wrap" title="The Special Birthday Message From Pink Floyd to David Gilmour Revealed"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="The Special Birthday Message From Pink Floyd to David Gilmour Revealed" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/david-gilmour-pink-floyd-smile-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/the-special-birthday-message-from-pink-floyd-to-david-gilmour-revealed/" rel="bookmark" title="The Special Birthday Message From Pink Floyd to David Gilmour Revealed">The Special Birthday Message From Pink Floyd to David Gilmour Revealed</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/kiss-star-paul-stanley-pays-his-tribute-to-kobe-bryant-in-an-amazing-way/" rel="bookmark" class="td-image-wrap" title="KISS Star Paul Stanley Pays His Tribute To Kobe Bryant In An Amazing Way"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="KISS Star Paul Stanley Pays His Tribute To Kobe Bryant In An Amazing Way" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/paul-stanley-kobe-bryant-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/kiss-star-paul-stanley-pays-his-tribute-to-kobe-bryant-in-an-amazing-way/" rel="bookmark" title="KISS Star Paul Stanley Pays His Tribute To Kobe Bryant In An Amazing Way">KISS Star Paul Stanley Pays His Tribute To Kobe Bryant In&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5e6580271b95b" data-td_block_id="td_uid_1_5e6580271b95b"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_1_5e6580271b95b" data-td_block_id="td_uid_1_5e6580271b95b"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-360"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_2_5e658027201d0_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_2_5e658027201d0"><script>var block_td_uid_2_5e658027201d0=new tdBlock();block_td_uid_2_5e658027201d0.id="td_uid_2_5e658027201d0";block_td_uid_2_5e658027201d0.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"17","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_2_5e658027201d0_rand","tdc_css_class":"td_uid_2_5e658027201d0_rand","tdc_css_class_style":"td_uid_2_5e658027201d0_rand_style"}';block_td_uid_2_5e658027201d0.td_column_number="3";block_td_uid_2_5e658027201d0.block_type="td_block_mega_menu";block_td_uid_2_5e658027201d0.post_count="5";block_td_uid_2_5e658027201d0.found_posts="781";block_td_uid_2_5e658027201d0.header_color="";block_td_uid_2_5e658027201d0.ajax_pagination_infinite_stop="";block_td_uid_2_5e658027201d0.max_num_pages="157";tdBlocksArray.push(block_td_uid_2_5e658027201d0);</script><div id=td_uid_2_5e658027201d0 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" class="td-image-wrap" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/lars-ulrich-jessica-miller-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way">Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" class="td-image-wrap" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-stanley-kubrick-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer">Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" class="td-image-wrap" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-max-portnoy-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life">Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" class="td-image-wrap" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/megadeth-electra-mustaine-beauty-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini">Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" class="td-image-wrap" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/nergal-billie-eilish-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”">Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_5e658027201d0" data-td_block_id="td_uid_2_5e658027201d0"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_5e658027201d0" data-td_block_id="td_uid_2_5e658027201d0"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-186"><a href="https://www.metalcastle.net/category/news/">NEWS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3808"><a href="https://www.metalcastle.net/category/news/others/">OTHERS</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-188"><a href="https://www.metalcastle.net/category/bands/">BANDS</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_3_5e65802724de8_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_3_5e65802724de8"><script>var block_td_uid_3_5e65802724de8=new tdBlock();block_td_uid_3_5e65802724de8.id="td_uid_3_5e65802724de8";block_td_uid_3_5e65802724de8.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"21","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_3_5e65802724de8_rand","tdc_css_class":"td_uid_3_5e65802724de8_rand","tdc_css_class_style":"td_uid_3_5e65802724de8_rand_style"}';block_td_uid_3_5e65802724de8.td_column_number="3";block_td_uid_3_5e65802724de8.block_type="td_block_mega_menu";block_td_uid_3_5e65802724de8.post_count="5";block_td_uid_3_5e65802724de8.found_posts="18";block_td_uid_3_5e65802724de8.header_color="";block_td_uid_3_5e65802724de8.ajax_pagination_infinite_stop="";block_td_uid_3_5e65802724de8.max_num_pages="4";tdBlocksArray.push(block_td_uid_3_5e65802724de8);</script><div id=td_uid_3_5e65802724de8 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/quiz-are-you-a-true-metallica-fan-or-poser/" rel="bookmark" class="td-image-wrap" title="QUIZ: Are You a True Metallica Fan or Poser?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="QUIZ: Are You a True Metallica Fan or Poser?" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/10/metallica-quiz-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/bands/" class="td-post-category">BANDS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/quiz-are-you-a-true-metallica-fan-or-poser/" rel="bookmark" title="QUIZ: Are You a True Metallica Fan or Poser?">QUIZ: Are You a True Metallica Fan or Poser?</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/quiz-are-you-true-james-hetfield-fan-or-not/" rel="bookmark" class="td-image-wrap" title="QUIZ: Are You True James Hetfield Fan or Not?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="QUIZ: Are You True James Hetfield Fan or Not?" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/09/james-hetfield-metallica-live-2019-u-billboard-1548-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/bands/" class="td-post-category">BANDS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/quiz-are-you-true-james-hetfield-fan-or-not/" rel="bookmark" title="QUIZ: Are You True James Hetfield Fan or Not?">QUIZ: Are You True James Hetfield Fan or Not?</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/quiz-are-you-a-true-metallica-fan-or-not/" rel="bookmark" class="td-image-wrap" title="QUIZ: Are You a True Metallica Fan or Not?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="QUIZ: Are You a True Metallica Fan or Not?" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/09/metallica-quiz-metalcastle.net_-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/bands/" class="td-post-category">BANDS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/quiz-are-you-a-true-metallica-fan-or-not/" rel="bookmark" title="QUIZ: Are You a True Metallica Fan or Not?">QUIZ: Are You a True Metallica Fan or Not?</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/lars-ulrich-posted-a-pop-quiz/" rel="bookmark" class="td-image-wrap" title="Lars Ulrich Posted a Pop Quiz"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Lars Ulrich Posted a Pop Quiz" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/09/346c988b-33d2-4f9f-8c99-ca27f7248f77-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/bands/" class="td-post-category">BANDS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/lars-ulrich-posted-a-pop-quiz/" rel="bookmark" title="Lars Ulrich Posted a Pop Quiz">Lars Ulrich Posted a Pop Quiz</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/she-used-metallica-to-scare-the-cougar-then-james-hetfield-called-her/" rel="bookmark" class="td-image-wrap" title="She Used Metallica to Scare the Cougar, Then James Hetfield Called Her"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="She Used Metallica to Scare the Cougar, Then James Hetfield Called Her" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/08/asdfasdf-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/bands/" class="td-post-category">BANDS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/she-used-metallica-to-scare-the-cougar-then-james-hetfield-called-her/" rel="bookmark" title="She Used Metallica to Scare the Cougar, Then James Hetfield Called Her">She Used Metallica to Scare the Cougar, Then James Hetfield Called&#8230;</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5e65802724de8" data-td_block_id="td_uid_3_5e65802724de8"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_3_5e65802724de8" data-td_block_id="td_uid_3_5e65802724de8"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-192"><a href="https://www.metalcastle.net/category/videos/">VIDEOS</a><ul class="sub-menu"><li class="menu-item-0"><div class="td-container-border"><div class="td-mega-grid"><div class="td_block_wrap td_block_mega_menu td_uid_4_5e65802728a43_rand td_with_ajax_pagination td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_4_5e65802728a43"><script>var block_td_uid_4_5e65802728a43=new tdBlock();block_td_uid_4_5e65802728a43.id="td_uid_4_5e65802728a43";block_td_uid_4_5e65802728a43.atts='{"limit":4,"td_column_number":3,"ajax_pagination":"next_prev","category_id":"19","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_4_5e65802728a43_rand","tdc_css_class":"td_uid_4_5e65802728a43_rand","tdc_css_class_style":"td_uid_4_5e65802728a43_rand_style"}';block_td_uid_4_5e65802728a43.td_column_number="3";block_td_uid_4_5e65802728a43.block_type="td_block_mega_menu";block_td_uid_4_5e65802728a43.post_count="4";block_td_uid_4_5e65802728a43.found_posts="90";block_td_uid_4_5e65802728a43.header_color="";block_td_uid_4_5e65802728a43.ajax_pagination_infinite_stop="";block_td_uid_4_5e65802728a43.max_num_pages="23";tdBlocksArray.push(block_td_uid_4_5e65802728a43);</script><div class="td_mega_menu_sub_cats"><div class="block-mega-child-cats"><a class="cur-sub-cat mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_5_5e6580272a0d5" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="" href="https://www.metalcastle.net/category/videos/">All</a><a class="mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_6_5e6580272a14a" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="28" href="https://www.metalcastle.net/category/videos/cover/">COVER</a><a class="mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_7_5e6580272a18b" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="31" href="https://www.metalcastle.net/category/videos/interviews/">INTERVIEWS</a><a class="mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_8_5e6580272a1c5" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="29" href="https://www.metalcastle.net/category/videos/live/">LIVE</a><a class="mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_9_5e6580272a1fe" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="40" href="https://www.metalcastle.net/category/videos/offical/">OFFICAL</a><a class="mega-menu-sub-cat-td_uid_4_5e65802728a43" id="td_uid_10_5e6580272a237" data-td_block_id="td_uid_4_5e65802728a43" data-td_filter_value="30" href="https://www.metalcastle.net/category/videos/other-videos/">OTHER</a></div></div><div id=td_uid_4_5e65802728a43 class="td_block_inner"><div class="td-mega-row"><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/jinjers-tatiana-shmailyuk-i-dont-care-what-people-think-about-the-album/" rel="bookmark" class="td-image-wrap" title="Jinjer&#8217;s Tatiana Shmailyuk: “I Don&#8217;t Care What People Think About the Album”"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Jinjer&#8217;s Tatiana Shmailyuk: “I Don&#8217;t Care What People Think About the Album”" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/11/tatiana-shmailyuk-jinjer-girl-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/videos/interviews/" class="td-post-category">INTERVIEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/jinjers-tatiana-shmailyuk-i-dont-care-what-people-think-about-the-album/" rel="bookmark" title="Jinjer&#8217;s Tatiana Shmailyuk: “I Don&#8217;t Care What People Think About the Album”">Jinjer&#8217;s Tatiana Shmailyuk: “I Don&#8217;t Care What People Think About the&#8230;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/david-ellefson-says-he-is-the-biggest-fan-of-ian-hill/" rel="bookmark" class="td-image-wrap" title="David Ellefson Says He is the Biggest Fan of Ian Hill"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="David Ellefson Says He is the Biggest Fan of Ian Hill" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/11/david-ellefson-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/videos/interviews/" class="td-post-category">INTERVIEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/david-ellefson-says-he-is-the-biggest-fan-of-ian-hill/" rel="bookmark" title="David Ellefson Says He is the Biggest Fan of Ian Hill">David Ellefson Says He is the Biggest Fan of Ian Hill</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/sharon-osbourne-talks-about-the-osbournes/" rel="bookmark" class="td-image-wrap" title="Sharon Osbourne Talks About &#8216;The Osbournes&#8217;"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Sharon Osbourne Talks About &#8216;The Osbournes&#8217;" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/10/the-osbournes-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/videos/interviews/" class="td-post-category">INTERVIEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/sharon-osbourne-talks-about-the-osbournes/" rel="bookmark" title="Sharon Osbourne Talks About &#8216;The Osbournes&#8217;">Sharon Osbourne Talks About &#8216;The Osbournes&#8217;</a></h3></div></div></div><div class="td-mega-span"><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/frankie-banali-shares-new-update-about-his-health-status/" rel="bookmark" class="td-image-wrap" title="Frankie Banali Shares New Update About His Health Status"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Frankie Banali Shares New Update About His Health Status" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2019/10/frankie-banali-cancer-treatment-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/videos/interviews/" class="td-post-category">INTERVIEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/frankie-banali-shares-new-update-about-his-health-status/" rel="bookmark" title="Frankie Banali Shares New Update About His Health Status">Frankie Banali Shares New Update About His Health Status</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_4_5e65802728a43" data-td_block_id="td_uid_4_5e65802728a43"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_4_5e65802728a43" data-td_block_id="td_uid_4_5e65802728a43"><i class="td-icon-font td-icon-menu-right"></i></a></div><div class="clearfix"></div></div></div></div></li></ul></li></ul></div></div><div class="header-search-wrap"><div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a></div><div class="td-drop-down-search" aria-labelledby="td-header-search-button"><form method="get" class="td-search-form" action="https://www.metalcastle.net/"><div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" /></div></form><div id="td-aj-search"></div></div></div></div></div></div><div class="td-banner-wrap-full td-banner-bg td-container-wrap "><div class="td-container-header td-header-row td-header-header"><div class="td-header-sp-recs"><div class="td-header-rec-wrap">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_11_5e6580272e080_rand td_block_template_14 "><style>.td_uid_11_5e6580272e080_rand.td-a-rec-img{text-align:left}.td_uid_11_5e6580272e080_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;</script> </div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-2"><article id="post-6931" class="post-6931 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-rock tag-news tag-queen tag-queen-news tag-rock tag-rock-news" itemscope itemtype="https://schema.org/Article"><div class="td-pb-row"><div class="td-pb-span12"><div class="td-post-header"><div class="td-crumb-container"><div class="entry-crumbs"><span><a title="View all posts in NEWS" class="entry-crumb" href="https://www.metalcastle.net/category/news/">NEWS</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Queen Remembers The Band&#8217;s Special Day</span></div></div><ul class="td-category"><li class="entry-category"><a href="https://www.metalcastle.net/category/news/">NEWS</a></li><li class="entry-category"><a href="https://www.metalcastle.net/category/news/rock/">ROCK</a></li></ul><header class="td-post-title"><h1 class="entry-title">Queen Remembers The Band&#8217;s Special Day</h1><div class="td-module-meta-info"><div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a><div class="td-author-line"> -</div></div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T23:28:40+00:00">March 8, 2020</time></span><div class="td-post-comments"><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/#respond"><i class="td-icon-comments"></i>0</a></div></div></header></div></div></div><div class="td-pb-row"><div class="td-pb-span8 td-main-content" role="main"><div class="td-ss-main-content"><div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-padding td-ps-bar td-post-sharing-style6 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.metalcastle.net%2Fqueen-remembers-the-bands-special-day%2F"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Queen+Remembers+The+Band%E2%80%99s+Special+Day&url=https%3A%2F%2Fwww.metalcastle.net%2Fqueen-remembers-the-bands-special-day%2F&via=metalcastlenet"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.metalcastle.net/queen-remembers-the-bands-special-day/&amp;media=https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg&description=Queen+Remembers+The+Band%E2%80%99s+Special+Day"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.metalcastle.net/queen-remembers-the-bands-special-day/&title=Queen+Remembers+The+Band%E2%80%99s+Special+Day"><div class="td-social-but-icon"><i class="td-icon-reddit"></i></div><div class="td-social-but-text">ReddIt</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#f4cb8781969e919780c9a58191919ad4a69199919996918687d4a09c91d4b6959a90d2d7ccc6c5c3cf87d4a78491979d9598d4b0958dd2969b908dc99c80808487cedbdb838383da9991809598979587809891da9a9180db858191919ad9869199919996918687d9809c91d996959a9087d9878491979d9598d990958ddb"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div>
</a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-tumblr" href="https://www.tumblr.com/share/link?url=https://www.metalcastle.net/queen-remembers-the-bands-special-day/&name=Queen Remembers The Band&#8217;s Special Day"><div class="td-social-but-icon"><i class="td-icon-tumblr"></i></div><div class="td-social-but-text">Tumblr</div>
</a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top"><div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div><div class="td-post-content"><div class="td-post-featured-image"><a href="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg" data-caption=""><img width="696" height="395" class="entry-thumb td-modal-image" src="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-696x395.jpg" srcset="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-696x395.jpg 696w, https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-300x170.jpg 300w, https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-768x436.jpg 768w, https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old-739x420.jpg 739w, https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg 850w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="queen-black-white-old" /></a></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_top td_uid_12_5e65802733561_rand td_block_template_14 "><style>.td_uid_12_5e65802733561_rand.td-a-rec-img{text-align:left}.td_uid_12_5e65802733561_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script> </div><p>The 50-year legendary <a href="http://metalcastle.net/tag/rock/" target="_blank" rel="noopener noreferrer"><strong><span style="color: #ff0000;">rock</span></strong></a> band <a href="http://metalcastle.net/tag/queen/" target="_blank" rel="noopener noreferrer"><strong><span style="color: #ff0000;">Queen</span></strong></a> has just updated its social media account and celebrated the anniversary of the band&#8217;s second studio album called <strong>Queen II</strong>, which was released on March 8, 1974.</p><p>In the photo, there was a legendary members of the <strong>Queen</strong>. Also, <span style="color: #ff0000;"><a style="color: #ff0000;" href="http://metalcastle.net/tag/freddie-mercury/" target="_blank" rel="noopener noreferrer"><strong>Freddie Mercury</strong></a></span>, who died at the age of 45 due to bronchial pneumonia resulting from AIDS, was remarkable in the photo. Because he tied his hands like X under his neck.</p><p>“46 Years Old Today! ‘<strong>Queen II</strong>.’ What’s your favourite Track from the LP,” <strong>Queen</strong> wrote in the caption of the post they shared.</p><p>The album, in which <strong>progressive rock</strong> elements came to the fore, was released on March 8, 1974 and gained the title of <strong>Queen</strong>&#8216;s second album.</p><blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/B9eNaBVFH3t/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/B9eNaBVFH3t/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"></p><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p></a></p><p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/B9eNaBVFH3t/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">46 Years Old Today! ‘Queen II’ 👑 What’s your favourite Track from the LP? 🎶 #Queen</a></p><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/officialqueenmusic/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Queen</a> (@officialqueenmusic) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-03-08T12:06:51+00:00">Mar 8, 2020 at 5:06am PDT</time></p></div></blockquote><p><script async src="//www.instagram.com/embed.js"></script></p> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom td_uid_13_5e65802733872_rand td_block_template_14 "><style>.td_uid_13_5e65802733872_rand.td-a-rec-img{text-align:left}.td_uid_13_5e65802733872_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script> </div></div><footer><div class="td-post-source-tags"><ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.metalcastle.net/tag/news/">news</a></li><li><a href="https://www.metalcastle.net/tag/queen/">queen</a></li><li><a href="https://www.metalcastle.net/tag/queen-news/">queen news</a></li><li><a href="https://www.metalcastle.net/tag/rock/">rock</a></li><li><a href="https://www.metalcastle.net/tag/rock-news/">rock news</a></li></ul></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/">Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way</a></div></div><div class="td-next-prev-separator"></div></div><div class="author-box-wrap"><a href="https://www.metalcastle.net/author/eray-erel/"><img src="https://www.metalcastle.net/wp-content/uploads/2020/01/eray-erel-metalcastlenet-150x150.png" width="96" height="96" alt="Eray Erel" class="avatar avatar-96 wp-user-avatar wp-user-avatar-96 alignnone photo" /></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a></span></div><div class="td-author-url"><a href="https://www.metalcastle.net">https://www.metalcastle.net</a></div><div class="td-author-description">Hello dear Readers, I'm Eray.
English is not my first language and I could make a grammar mistake. I'm trying to improve my English every day and I won't stop till I exactly learn. Thank you for your understanding. Please contact me if you have any problems or questions: <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="b9dccbd8c0f9d4dccdd8d5dad8cacdd5dc97d7dccd">[email&#160;protected]</a></div><div class="td-author-social">
<span class="td-social-icon-wrap">
<a target="_blank" href="erayerell" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#2e4b5c4f576e434b5a4f424d4f5d5a424b00404b5a" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/_erayerel" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Eray Erel"></span><meta itemprop="datePublished" content="2020-03-08T23:28:40+00:00"><meta itemprop="dateModified" content="2020-03-08T23:28:40+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.metalcastle.net/wp-content/uploads/2019/11/noname-1.png"></span><meta itemprop="name" content="MetalCastle - All about Rock and Metal"></span><meta itemprop="headline " content="Queen Remembers The Band&#039;s Special Day"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg"><meta itemprop="width" content="850"><meta itemprop="height" content="483"></span></footer><div class="td_block_wrap td_block_related_posts td_uid_14_5e658027346e7_rand td_with_ajax_pagination td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_14_5e658027346e7"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_td_uid_14_5e658027346e7=new tdBlock();block_td_uid_14_5e658027346e7.id="td_uid_14_5e658027346e7";block_td_uid_14_5e658027346e7.atts='{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_14_5e658027346e7_rand","td_column_number":3,"live_filter_cur_post_id":6931,"live_filter_cur_post_author":"4","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_14_5e658027346e7_rand","tdc_css_class_style":"td_uid_14_5e658027346e7_rand_style"}';block_td_uid_14_5e658027346e7.td_column_number="3";block_td_uid_14_5e658027346e7.block_type="td_block_related_posts";block_td_uid_14_5e658027346e7.post_count="6";block_td_uid_14_5e658027346e7.found_posts="1246";block_td_uid_14_5e658027346e7.header_color="";block_td_uid_14_5e658027346e7.ajax_pagination_infinite_stop="";block_td_uid_14_5e658027346e7.max_num_pages="208";tdBlocksArray.push(block_td_uid_14_5e658027346e7);</script><h4 class="td-related-title td-block-title"><a id="td_uid_15_5e65802736f6b" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_14_5e658027346e7" href="#">LATEST POSTS</a><a id="td_uid_16_5e65802736f71" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_14_5e658027346e7" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_14_5e658027346e7 class="td_block_inner"><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" class="td-image-wrap" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/lars-ulrich-jessica-miller-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way">Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" class="td-image-wrap" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/chris-slade-david-gilmour-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour">AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" class="td-image-wrap" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-stanley-kubrick-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer">Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer</a></h3></div></div></div></div><div class="td-related-row"><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" class="td-image-wrap" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-max-portnoy-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life">Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" class="td-image-wrap" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/megadeth-electra-mustaine-beauty-218x150.jpg" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini">Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini</a></h3></div></div></div><div class="td-related-span4"><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class="td-module-image"><div class="td-module-thumb"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" class="td-image-wrap" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/nergal-billie-eilish-218x150.png" width="218" height="150" /></a></div> <a href="https://www.metalcastle.net/category/news/metal/" class="td-post-category">METAL</a></div><div class="item-details"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”">Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”</a></h3></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_14_5e658027346e7" data-td_block_id="td_uid_14_5e658027346e7"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_14_5e658027346e7" data-td_block_id="td_uid_14_5e658027346e7"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div id="disqus_thread"></div></div></div><div class="td-pb-span4 td-main-sidebar" role="complementary"><div class="td-ss-main-sidebar"><aside class="td_block_template_14 widget widget_search"><form method="get" class="td-search-form-widget" action="https://www.metalcastle.net/"><div role="search">
<input class="td-widget-search-input" type="text" value="" name="s" id="s" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="searchsubmit" value="Search" /></div></form></aside><div class="td_block_wrap td_block_slide td_block_widget td_uid_17_5e65802739f3b_rand td-pb-border-top td_block_template_14" data-td-block-uid="td_uid_17_5e65802739f3b"><style>.td_uid_17_5e65802739f3b_rand .td-slide-meta{max-width:calc(100% + 44px)}@media (max-width:767px){.td_uid_17_5e65802739f3b_rand .td-slide-meta{max-width:calc(100% + 24px)}}.td_uid_17_5e65802739f3b_rand .entry-thumb{background-position:center 50%}.td_uid_17_5e65802739f3b_rand .slide-meta-cat{display:inline-block}.td_uid_17_5e65802739f3b_rand .td-post-author-name{display:inline-block}.td_uid_17_5e65802739f3b_rand .td-post-date,.td_uid_17_5e65802739f3b_rand .td-post-author-name span{display:inline-block}.td_uid_17_5e65802739f3b_rand .td-post-comments{display:inline-block}.td_uid_17_5e65802739f3b_rand .td-slide-nav{font-size:55px}</style><script>var block_td_uid_17_5e65802739f3b=new tdBlock();block_td_uid_17_5e65802739f3b.id="td_uid_17_5e65802739f3b";block_td_uid_17_5e65802739f3b.atts='{"custom_title":"TRENDING","custom_url":"","block_template_id":"","header_text_color":"#","header_color":"#","border_color":"#","accent_text_color":"#","autoplay":"2","limit":"7","offset":"","el_class":"","post_ids":"","category_id":"22","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","image_size":"td_1920x0","meta_info_horiz":"content-horiz-left","meta_info_vert":"content-vert-bottom","title_color":"#","cat_bg":"#","cat_txt":"#","cat_bg_hover":"#","cat_txt_hover":"#","author_txt":"#","author_txt_hover":"#","date_txt":"#","comm_txt":"#","review_stars":"#","nav_icons_color":"#","class":"td_block_widget td_uid_17_5e65802739f3b_rand","separator":"","show_modified_date":"","content_width":"","image_alignment":"50","image_height":"","meta_padding":"","art_title_space":"","category_margin":"","category_padding":"","category_radius":"0","show_cat":"inline-block","show_author":"inline-block","show_date":"inline-block","show_com":"inline-block","prev_tdicon":"","next_tdicon":"","nav_icon_size":"55","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","msf_title_font_header":"","msf_title_font_title":"Article title","msf_title_font_settings":"","msf_title_font_family":"","msf_title_font_size":"","msf_title_font_line_height":"","msf_title_font_style":"","msf_title_font_weight":"","msf_title_font_transform":"","msf_title_font_spacing":"","msf_title_":"","msf_cat_font_title":"Article category tag","msf_cat_font_settings":"","msf_cat_font_family":"","msf_cat_font_size":"","msf_cat_font_line_height":"","msf_cat_font_style":"","msf_cat_font_weight":"","msf_cat_font_transform":"","msf_cat_font_spacing":"","msf_cat_":"","msf_meta_font_title":"Article meta info","msf_meta_font_settings":"","msf_meta_font_family":"","msf_meta_font_size":"","msf_meta_font_line_height":"","msf_meta_font_style":"","msf_meta_font_weight":"","msf_meta_font_transform":"","msf_meta_font_spacing":"","msf_meta_":"","color_overlay":"","color_overlay_h":"","css":"","tdc_css":"","td_column_number":1,"ajax_pagination_infinite_stop":"","color_preset":"","ajax_pagination":"","border_top":"","tdc_css_class":"td_uid_17_5e65802739f3b_rand","tdc_css_class_style":"td_uid_17_5e65802739f3b_rand_style"}';block_td_uid_17_5e65802739f3b.td_column_number="1";block_td_uid_17_5e65802739f3b.block_type="td_block_slide";block_td_uid_17_5e65802739f3b.post_count="7";block_td_uid_17_5e65802739f3b.found_posts="1254";block_td_uid_17_5e65802739f3b.header_color="#";block_td_uid_17_5e65802739f3b.ajax_pagination_infinite_stop="";block_td_uid_17_5e65802739f3b.max_num_pages="180";tdBlocksArray.push(block_td_uid_17_5e65802739f3b);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>TRENDING</span></h4></div><div id=td_uid_17_5e65802739f3b class="td_block_inner"><div id="td_uid_18_5e6580273d35b" class="td-theme-slider iosSlider-col-1 td_mod_wrap"><div class="td-slider "><div id="td_uid_18_5e6580273d35b_item_0" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" rel="bookmark" class="td-image-wrap" title="Queen Remembers The Band&#8217;s Special Day"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/queen-black-white-old.jpg"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/">NEWS</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/" rel="bookmark" title="Queen Remembers The Band&#8217;s Special Day">Queen Remembers The Band&#8217;s Special Day</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T23:28:40+00:00">March 8, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/queen-remembers-the-bands-special-day/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_1" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" class="td-image-wrap" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/lars-ulrich-jessica-miller.jpg"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/" rel="bookmark" title="Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way">Metallica&#8217;s Lars Ulrich and His Wife Celebrates Their Special Day In A Bizarre Way</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T13:37:08+00:00">March 8, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/metallicas-lars-ulrich-and-his-wife-celebrates-their-special-day-in-a-bizarre-way/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_2" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" class="td-image-wrap" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/chris-slade-david-gilmour.png"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/">NEWS</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/" rel="bookmark" title="AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour">AC/DC&#8217;s Legendary Drummer Recalls His Rare-Known Conversation With David Gilmour</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/gorkem-erel/">Gorkem Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T05:00:23+00:00">March 8, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/ac-dcs-legendary-drummer-recalls-his-rare-known-conversation-with-david-gilmour/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_3" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" class="td-image-wrap" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-stanley-kubrick.png"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/" rel="bookmark" title="Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer">Sons Of Apollo&#8217;s Mike Portnoy Still Sad For The Devastating Death Of Legendary Producer</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T03:00:47+00:00">March 8, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/sons-of-apollos-mike-portnoy-still-sad-for-the-devastating-death-of-legendary-producer/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_4" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" class="td-image-wrap" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/mike-portnoy-max-portnoy.png"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/" rel="bookmark" title="Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life">Ex-Dream Theater Star Mike Portnoy Reveals One Of The Greatest Days Of His Life</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-08T01:00:19+00:00">March 8, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/ex-dream-theater-star-mike-portnoy-reveals-one-of-the-greatest-days-of-his-life/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_5" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" class="td-image-wrap" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/megadeth-electra-mustaine-beauty.jpg"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/" rel="bookmark" title="Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini">Megadeth&#8217;s Dave Mustaine&#8217;s Daughter Shows Her Sweetness With Her Leopard Bikini</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-07T23:00:43+00:00">March 7, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/megadeths-dave-mustaines-daughter-shows-her-sweetness-with-her-leopard-bikini/#respond">0</a></div></div></div></div><div id="td_uid_18_5e6580273d35b_item_6" class="td_module_slide td-animation-stack td-image-gradient"><div class="td-module-thumb"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" class="td-image-wrap" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”"><span class="entry-thumb td-thumb-css" data-type="css_image" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/nergal-billie-eilish.png"></span></a></div><div class="td-slide-meta"><span class="slide-meta-cat"><a href="https://www.metalcastle.net/category/news/metal/">METAL</a></span><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/" rel="bookmark" title="Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”">Behemoth&#8217;s Nergal Praises Billie Eilish: “I Can Respect What Billie Eilish Does”</a></h3><div class="td-module-meta-info"><span class="td-post-author-name"><a href="https://www.metalcastle.net/author/talha-cetinbas/">Talha Cetinbas</a> <span>-</span> </span><span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-07T20:00:40+00:00">March 7, 2020</time></span><div class="td-post-comments"><i class="td-icon-comments"></i><a href="https://www.metalcastle.net/behemoths-nergal-praises-billie-eilish-i-can-respect-what-billie-eilish-does/#respond">0</a></div></div></div></div></div><i class="td-slide-nav td-icon-left prevButton"></i><i class="td-slide-nav td-icon-right nextButton"></i></div></div></div><div class="td_block_wrap td_block_14 td_block_widget td_uid_19_5e65802740280_rand td-pb-full-cell td_with_ajax_pagination td-pb-border-top td_block_template_14 td-column-1" data-td-block-uid="td_uid_19_5e65802740280"><script>var block_td_uid_19_5e65802740280=new tdBlock();block_td_uid_19_5e65802740280.id="td_uid_19_5e65802740280";block_td_uid_19_5e65802740280.atts='{"custom_title":"OTHERS","custom_url":"","block_template_id":"","header_text_color":"#","header_color":"#","border_color":"#","accent_text_color":"#","mx1_tl":"","limit":"9","offset":"","el_class":"","post_ids":"","category_id":"27","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_19_5e65802740280_rand","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","mx1f_title_font_header":"","mx1f_title_font_title":"Article title","mx1f_title_font_settings":"","mx1f_title_font_family":"","mx1f_title_font_size":"","mx1f_title_font_line_height":"","mx1f_title_font_style":"","mx1f_title_font_weight":"","mx1f_title_font_transform":"","mx1f_title_font_spacing":"","mx1f_title_":"","mx1f_cat_font_title":"Article category tag","mx1f_cat_font_settings":"","mx1f_cat_font_family":"","mx1f_cat_font_size":"","mx1f_cat_font_line_height":"","mx1f_cat_font_style":"","mx1f_cat_font_weight":"","mx1f_cat_font_transform":"","mx1f_cat_font_spacing":"","mx1f_cat_":"","mx1f_meta_font_title":"Article meta info","mx1f_meta_font_settings":"","mx1f_meta_font_family":"","mx1f_meta_font_size":"","mx1f_meta_font_line_height":"","mx1f_meta_font_style":"","mx1f_meta_font_weight":"","mx1f_meta_font_transform":"","mx1f_meta_font_spacing":"","mx1f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_19_5e65802740280_rand","tdc_css_class_style":"td_uid_19_5e65802740280_rand_style"}';block_td_uid_19_5e65802740280.td_column_number="1";block_td_uid_19_5e65802740280.block_type="td_block_14";block_td_uid_19_5e65802740280.post_count="9";block_td_uid_19_5e65802740280.found_posts="214";block_td_uid_19_5e65802740280.header_color="#";block_td_uid_19_5e65802740280.ajax_pagination_infinite_stop="";block_td_uid_19_5e65802740280.max_num_pages="24";tdBlocksArray.push(block_td_uid_19_5e65802740280);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span>OTHERS</span></h4></div><div id=td_uid_19_5e65802740280 class="td_block_inner td-column-1"><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/megadeth-icon-dave-mustaines-daughters-mind-blowing-body-shines-under-the-sun/" rel="bookmark" class="td-image-wrap" title="Megadeth Icon Dave Mustaine&#8217;s Daughter&#8217;s Mind-Blowing Body Shines Under The Sun"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Megadeth Icon Dave Mustaine&#8217;s Daughter&#8217;s Mind-Blowing Body Shines Under The Sun" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/electra-mustaine-gorgeous-look-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/megadeth-icon-dave-mustaines-daughters-mind-blowing-body-shines-under-the-sun/" rel="bookmark" title="Megadeth Icon Dave Mustaine&#8217;s Daughter&#8217;s Mind-Blowing Body Shines Under The Sun">Megadeth Icon Dave Mustaine&#8217;s Daughter&#8217;s Mind-Blowing Body Shines Under The Sun</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/sami-altintas/">Sami Altintas</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-05T19:00:41+00:00">March 5, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/dave-mustaines-daughter-shows-her-stunning-body-with-her-leopard-bikini/" rel="bookmark" class="td-image-wrap" title="Dave Mustaine&#8217;s Daughter Shows Her Stunning Body With Her Leopard Bikini"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Dave Mustaine&#8217;s Daughter Shows Her Stunning Body With Her Leopard Bikini" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/03/electra-mustaine-street-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/dave-mustaines-daughter-shows-her-stunning-body-with-her-leopard-bikini/" rel="bookmark" title="Dave Mustaine&#8217;s Daughter Shows Her Stunning Body With Her Leopard Bikini">Dave Mustaine&#8217;s Daughter Shows Her Stunning Body With Her Leopard Bikini</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-03-05T02:00:56+00:00">March 5, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/lars-ulrichs-wife-shows-her-stunning-eyes-with-a-mesmerizing-photo/" rel="bookmark" class="td-image-wrap" title="Lars Ulrich&#8217;s Wife Shows Her Stunning Eyes With A Mesmerizing Photo"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Lars Ulrich&#8217;s Wife Shows Her Stunning Eyes With A Mesmerizing Photo" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/jessica-miller-metallica-356x220.jpeg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/lars-ulrichs-wife-shows-her-stunning-eyes-with-a-mesmerizing-photo/" rel="bookmark" title="Lars Ulrich&#8217;s Wife Shows Her Stunning Eyes With A Mesmerizing Photo">Lars Ulrich&#8217;s Wife Shows Her Stunning Eyes With A Mesmerizing Photo</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/muharrem-dogan/">Muharrem Doğan</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-29T15:00:34+00:00">February 29, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/guns-n-roses-stars-daughter-shows-her-perfect-body-in-public/" rel="bookmark" class="td-image-wrap" title="Guns N&#8217; Roses Star&#8217;s Daughter Shows Her Perfect Body In Public"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Guns N&#8217; Roses Star&#8217;s Daughter Shows Her Perfect Body In Public" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/mae-mckagan-black-hot-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/guns-n-roses-stars-daughter-shows-her-perfect-body-in-public/" rel="bookmark" title="Guns N&#8217; Roses Star&#8217;s Daughter Shows Her Perfect Body In Public">Guns N&#8217; Roses Star&#8217;s Daughter Shows Her Perfect Body In Public</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/eray-erel/">Eray Erel</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-23T15:00:04+00:00">February 23, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/alicia-dove-breaks-her-silence-after-the-tragic-death-of-relationship-therapist/" rel="bookmark" class="td-image-wrap" title="Alicia Dove Breaks Her Silence After The Tragic Death Of Relationship Therapist"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Alicia Dove Breaks Her Silence After The Tragic Death Of Relationship Therapist" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/alicia-dove-amie-harwick-356x220.png" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/alicia-dove-breaks-her-silence-after-the-tragic-death-of-relationship-therapist/" rel="bookmark" title="Alicia Dove Breaks Her Silence After The Tragic Death Of Relationship Therapist">Alicia Dove Breaks Her Silence After The Tragic Death Of Relationship Therapist</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/talha-cetinbas/">Talha Cetinbas</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-20T16:30:50+00:00">February 20, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/ozzy-osbournes-son-breaks-his-silence-after-disrespectful-comments/" rel="bookmark" class="td-image-wrap" title="Ozzy Osbourne&#8217;s Son Breaks His Silence After Disrespectful Comments"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Ozzy Osbourne&#8217;s Son Breaks His Silence After Disrespectful Comments" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/jack-osbourne-angry-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/ozzy-osbournes-son-breaks-his-silence-after-disrespectful-comments/" rel="bookmark" title="Ozzy Osbourne&#8217;s Son Breaks His Silence After Disrespectful Comments">Ozzy Osbourne&#8217;s Son Breaks His Silence After Disrespectful Comments</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/sami-altintas/">Sami Altintas</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-20T06:30:45+00:00">February 20, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/metallica-icon-lars-ulrichs-wifes-sweet-selfie-with-chicken-revealed/" rel="bookmark" class="td-image-wrap" title="Metallica Icon Lars Ulrich&#8217;s Wife&#8217;s Sweet Selfie With Chicken Revealed"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Metallica Icon Lars Ulrich&#8217;s Wife&#8217;s Sweet Selfie With Chicken Revealed" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/jessica-miller-356x220.jpeg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/metallica-icon-lars-ulrichs-wifes-sweet-selfie-with-chicken-revealed/" rel="bookmark" title="Metallica Icon Lars Ulrich&#8217;s Wife&#8217;s Sweet Selfie With Chicken Revealed">Metallica Icon Lars Ulrich&#8217;s Wife&#8217;s Sweet Selfie With Chicken Revealed</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/muharrem-dogan/">Muharrem Doğan</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-19T00:30:15+00:00">February 19, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/corey-taylors-wife-alicia-dove-pisses-off-and-slams-the-trolls-after-the-sad-passing/" rel="bookmark" class="td-image-wrap" title="Corey Taylor&#8217;s Wife Alicia Dove Pisses Off And Slams The Trolls After The Sad Passing"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Corey Taylor&#8217;s Wife Alicia Dove Pisses Off And Slams The Trolls After The Sad Passing" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/alicia-dove-corey-taylor-angry-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/corey-taylors-wife-alicia-dove-pisses-off-and-slams-the-trolls-after-the-sad-passing/" rel="bookmark" title="Corey Taylor&#8217;s Wife Alicia Dove Pisses Off And Slams The Trolls After The Sad Passing">Corey Taylor&#8217;s Wife Alicia Dove Pisses Off And Slams The Trolls After The Sad Passing</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/sami-altintas/">Sami Altintas</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-18T07:30:06+00:00">February 18, 2020</time></span> </span></div></div></div></div><div class="td-block-span12"><div class="td_module_mx1 td_module_wrap td-animation-stack"><div class="td-module-thumb"><a href="https://www.metalcastle.net/motley-crue-star-tommy-lee-smoking-on-his-wifes-feet/" rel="bookmark" class="td-image-wrap" title="Motley Crue Star Tommy Lee Smoking On His Wife&#8217;s Feet"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAWQAAADcAQMAAAB9O0nPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAACBJREFUaN7twTEBAAAAwiD7p7bDbmAAAAAAAAAAAABAdieIAAGQh2mWAAAAAElFTkSuQmCC" alt="" title="Motley Crue Star Tommy Lee Smoking On His Wife&#8217;s Feet" data-type="image_tag" data-img-url="https://www.metalcastle.net/wp-content/uploads/2020/02/tommy-lee-brittany-furlan-lee-kiss-356x220.jpg" width="356" height="220" /></a></div><div class="td-module-meta-info"><h3 class="entry-title td-module-title"><a href="https://www.metalcastle.net/motley-crue-star-tommy-lee-smoking-on-his-wifes-feet/" rel="bookmark" title="Motley Crue Star Tommy Lee Smoking On His Wife&#8217;s Feet">Motley Crue Star Tommy Lee Smoking On His Wife&#8217;s Feet</a></h3><div class="td-editor-date">
<a href="https://www.metalcastle.net/category/news/" class="td-post-category">NEWS</a> <span class="td-author-date">
<span class="td-post-author-name"><a href="https://www.metalcastle.net/author/talha-cetinbas/">Talha Cetinbas</a> <span>-</span> </span> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-02-17T05:30:37+00:00">February 17, 2020</time></span> </span></div></div></div></div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_19_5e65802740280" data-td_block_id="td_uid_19_5e65802740280"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_19_5e65802740280" data-td_block_id="td_uid_19_5e65802740280"><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div class="clearfix"></div></div></div></div></article></div></div><div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-4 "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span12">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-footer_top td_uid_20_5e658027483eb_rand td_block_template_14 "><style>.td_uid_20_5e658027483eb_rand.td-a-rec-img{text-align:left}.td_uid_20_5e658027483eb_rand.td-a-rec-img img{margin:0 auto 0 0}</style><script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=1019&&td_screen_width<1140){document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width>=768&&td_screen_width<1019){document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}
if(td_screen_width<768){document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-2430168791377618" data-ad-slot="4250389633"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script> </div></div></div><div class="td-pb-row"><div class="td-pb-span12"><div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.metalcastle.net/"><img src="https://www.metalcastle.net/wp-content/uploads/2019/11/noname-3.png" alt="" title="" /></a></div><div class="footer-text-wrap">At MetalCastle we publish videos, tours, photos, lists and news about all Rock & Metal World.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#32515d5c46535146725f5746535e515341465e571c5c5746"><span class="__cf_email__" data-cfemail="98fbf7f6ecf9fbecd8f5fdecf9f4fbf9ebecf4fdb6f6fdec">[email&#160;protected]</span></a></div></div><div class="footer-social-wrap td-social-style-2">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/metalcastlenet" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.instagram.com/metalcastle_official/" title="Instagram">
<i class="td-icon-font td-icon-instagram"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.reddit.com/user/metalcastle_net" title="Reddit">
<i class="td-icon-font td-icon-reddit"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/metalcastlenet" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.youtube.com/channel/UCcSTPDmL6d7rNodaHqBCeVg" title="Youtube">
<i class="td-icon-font td-icon-youtube"></i>
</a>
</span></div></div></div></div></div></div><div class="td-sub-footer-container td-container-wrap "><div class="td-container"><div class="td-pb-row"><div class="td-pb-span td-sub-footer-menu"><div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-3332" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-3332"><a href="https://www.metalcastle.net/about-us/">ABOUT US</a></li><li id="menu-item-3333" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3333"><a href="https://www.metalcastle.net/contact/">CONTACT</a></li><li id="menu-item-3334" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy td-menu-item td-normal-menu menu-item-3334"><a href="https://www.metalcastle.net/privacy-policy/">PRIVACY POLICY</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy">
&copy; MetalCastle. All Rights Reserved 2019.</div></div></div></div></div> <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>var adsforwp_obj={"ajax_url":"https:\/\/www.metalcastle.net\/wp-admin\/admin-ajax.php","adsforwp_front_nonce":"3076a4d098"};</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/2c2fc.js'></script> <script type='text/javascript'>var adsforwp_browser_obj=[];</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/1396b.js'></script> <script type='text/javascript'>var wpcf7={"apiSettings":{"root":"https:\/\/www.metalcastle.net\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/9e448.js'></script> <script type='text/javascript'>var countVars={"disqusShortname":"metalcastle-1"};</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/71bdd.js'></script> <script type='text/javascript'>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"6931 https:\/\/www.metalcastle.net\/?p=6931","disqusShortname":"metalcastle-1","disqusTitle":"Queen Remembers The Band\u2019s Special Day","disqusUrl":"https:\/\/www.metalcastle.net\/queen-remembers-the-bands-special-day\/","postId":"6931"};</script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/ac631.js'></script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/0fbe0.js'></script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/930a3.js'></script> <script data-optimized='1' type='text/javascript' src='https://www.metalcastle.net/min/d05df89542fda0d20388eea0e3a31817.js'></script> <script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script> <script>jQuery(document).ready(function(){jQuery("#td_uid_18_5e6580273d35b").iosSlider({snapToChildren:true,desktopClickDrag:true,keyboardControls:false,responsiveSlideContainer:true,responsiveSlides:true,autoSlide:true,autoSlideTimer:2000,infiniteSlider:true,navPrevSelector:jQuery("#td_uid_18_5e6580273d35b .prevButton"),navNextSelector:jQuery("#td_uid_18_5e6580273d35b .nextButton"),});});(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.metalcastle.net/wp-content/themes/Newspaper/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.metalcastle.net/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}
var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}
var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script> <div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: #000;"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button wp-default button">OK</a><a href="https://www.metalcastle.net/privacy-policy/" target="_blank" id="cn-more-info" class="cn-more-info cn-button wp-default button">PRIVACY POLICY</a></span></div></div></body></html>

